GitHub Advisoryadvisory · Go
GHSA-pr72-8fxw-xx22 Default Credentials in nginx-defender Configuration Files
MEDIUM
Official page ↗
- Aliases
- CVE-2025-55740
- Ecosystem
- Go
- Packages
- github.com/Anipaleja/nginx-defender
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-1392
- Reviewed
- 2025-08-19
Affected packages
• Go github.com/Anipaleja/nginx-defender: < 1.5.0 → fixed in 1.5.0
Description
Impact
This is a configuration vulnerability affecting nginx-defender deployments. Example configuration files
config.yaml, docker-compose.yml contain default credentials (`default_password: "change_me_please"`, `GF_SECURITY_ADMIN_PASSWORD=admin123`). If users deploy nginx-defender without changing these defaults, attackers with network access could gain administrative control, bypassing security protections.
Who is impacted?
All users who deploy nginx-defender with default credentials and expose the admin interface to untrusted networks.
Patches
The issue is addressed in v1.5.0 and later.
Startup warnings are added if default credentials are detected.
Documentation now strongly recommends changing all default passwords before deployment.
Patched versions:
1.5.0 and later
Will be fully patched in v1.7.0 and later
Workarounds
Users can remediate the vulnerability without upgrading by manually changing all default credentials in configuration files before deployment:
```yaml
config.yaml
auth:
default_password: "your_strong_password_here"
```
```yml
docker-compose.yml
• GF_SECURITY_ADMIN_PASSWORD=your_strong_password
```
Restrict access to the admin interface and use environment variables for secrets.
References
• Security Configuration Guide
• Full Security Advisory
• Library README
• README
Related
Alias · CVE (1)
- CVE-2025-55740 nginx-defender is a high-performance, enterprise-grade Web Application Firewall (WAF) and threat detection system engineered for modern web… vulnerability
Weakness · CWE (1)
- CWE-1392 Use of Default Credentials weakness