GitHub Advisoryadvisory · Packagist
GHSA-prcg-mc23-hgjh phpmyadmin contains SQL Injection vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2020-22452
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2023-02-02
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 5.0.0, < 5.0.2 → fixed in 5.0.2
Description
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.0.2 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
Related
Alias · CVE (1)
- CVE-2020-22452 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the… vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-22452 advisory
- https://github.com/phpmyadmin/phpmyadmin/issues/15898 web
- https://github.com/phpmyadmin/phpmyadmin/pull/16004 web
- https://github.com/phpmyadmin/phpmyadmin/commit/bc982466f08ddccad4804ba928f84ff8e25107cb web
- https://github.com/phpmyadmin/phpmyadmin package