GitHub Advisoryadvisory · PyPI
GHSA-prgp-w7vf-ch62 LangChain vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2023-39659
- Ecosystem
- PyPI
- Packages
- langchain
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2023-08-15
Affected packages
• PyPI langchain: < 0.0.325 → fixed in 0.0.325
Description
An issue in langchain langchain-ai before version 0.0.325 allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
Related
Alias · CVE (1)
- CVE-2023-39659 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the… vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39659 advisory
- https://github.com/langchain-ai/langchain/issues/7700 web
- https://github.com/langchain-ai/langchain/pull/12427 web
- https://github.com/langchain-ai/langchain/pull/5640 web
- https://github.com/langchain-ai/langchain/commit/cadfce295f8a33828fc635c2e5ea28b883e5c992 web
- https://github.com/langchain-ai/langchain package
- https://github.com/langchain-ai/langchain/releases/tag/v0.0.325 web
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-147.yaml web