GitHub Advisoryadvisory · npm
GHSA-prr3-c3m5-p7q2 @adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity
MEDIUM
Official page ↗
- Aliases
- CVE-2023-48631
- Ecosystem
- npm
- Packages
- @adobe/css-tools
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
- Weaknesses
- CWE-1333, CWE-20
- Reviewed
- 2023-11-30
Affected packages
• npm @adobe/css-tools: < 4.3.2 → fixed in 4.3.2
Description
Impact
@adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.
Patches
The issue has been resolved in 4.3.2.
Workarounds
None
References
N/A
Related
Alias · CVE (1)
- CVE-2023-48631 @adobe/css-tools versions 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of… vulnerability
References
- https://github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-48631 advisory
- https://github.com/adobe/css-tools/issues/211 web
- https://github.com/adobe/css-tools/pull/249 web
- https://github.com/adobe/css-tools/commit/472bef91bde9caab305f3f36231ad0c253581b43 web
- https://github.com/adobe/css-tools package