GitHub Advisoryadvisory · Packagist
GHSA-pv2v-6w2v-97x6 Concrete CMS Vulnerable to Deserialization of Untrusted Data
HIGH
Official page ↗
- Aliases
- CVE-2026-8135
- Ecosystem
- Packagist
- Packages
- concrete5/concrete5
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- Weaknesses
- CWE-502
- Reviewed
- 2026-06-23
Affected packages
• Packagist concrete5/concrete5: < 9.5.1 → fixed in 9.5.1
Description
Concrete CMS 9.5.0 and below is vulnerable to Remote Code Execution due to insecure deserialization occurring in the ExpressEntryList block controller. An rogue administrator with privileges to add blocks to an area can bypass the intended protection mechanism (_fromCIF === true), which normally restricts malicious inputs over form POST requests, by leveraging the REST API functionality. Because the REST API parses requests using json_decode(), the string "true" is evaluated as a strict PHP Boolean(true). This bypass allows the attacker to inject a malicious serialized payload into the block's filterFields database column. The payload will subsequently be executed when the block's data is viewed or edited by an administrator leading to complete server takeover (RCE). Concrete CMS thanks Nguyễn Văn Thiện https://github.com/Thien225409 for reporting this issue.
Related
Alias · CVE (1)
- CVE-2026-8135 Concrete CMS 9.5.0 and below is vulnerable to Remote Code Execution due to insecure deserialization occurring in the ExpressEntryList block… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness