GitHub Advisoryadvisory · Maven

GHSA-pv38-mqpp-v72h Cross-site Scripting in Jenkins NS-ND Integration Performance Publisher Plugin

HIGH Published 2022-06-24 Modified 2022-12-05 Official page ↗
Aliases
CVE-2022-34191
Ecosystem
Maven
Packages
io.jenkins.plugins:cavisson-ns-nd-integration
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2022-07-05

Affected packages

• Maven io.jenkins.plugins:cavisson-ns-nd-integration: < 4.8.0.129 → fixed in 4.8.0.129

Description

Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix. Additionally, several plugins have previously been updated to list parameters in a way that prevents exploitation by default, see SECURITY-2617 in the 2022-04-12 security advisory for a list.

Related

Alias · CVE (1)

  • CVE-2022-34191 Jenkins NS-ND Integration Performance Publisher Plugin 4.8.0.77 and earlier does not escape the name of NetStorm Test parameters on views… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References