GitHub Advisoryadvisory · Packagist

GHSA-pvr5-84gr-g985 phpMyAdmin Implementation XSS Vulnerability on Server Monitor Page

MEDIUM Published 2022-05-14 Modified 2023-08-15 Official page ↗
Aliases
CVE-2014-8326
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2023-08-15

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.0.10.5 → fixed in 4.0.10.5 • Packagist phpmyadmin/phpmyadmin: >= 4.1.0, < 4.1.14.6 → fixed in 4.1.14.6 • Packagist phpmyadmin/phpmyadmin: >= 4.2.0, < 4.2.10.1 → fixed in 4.2.10.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the `libraries/DatabaseInterface.class.php` code for SQL debug output and the `js/server_status_monitor.js` code for the server monitor page.

Related

Alias · CVE (1)

  • CVE-2014-8326 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References