GitHub Advisoryadvisory · npm

GHSA-pvw4-cvr4-97p8 Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

CRITICAL Published 2026-05-20 Modified 2026-05-20 Official page ↗
Aliases
CVE-2026-46421
Ecosystem
npm
Packages
@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service
Severity
Critical
Weaknesses
CWE-506
Reviewed
2026-05-20

Affected packages

• npm @cap-js/sqlite: >= 2.2.2, < 2.3.0 → fixed in 2.3.0 • npm @cap-js/postgres: >= 2.2.2, < 2.3.0 → fixed in 2.3.0 • npm @cap-js/db-service: >= 2.10.1, < 2.11.0 → fixed in 2.11.0

Description

Impact On April 29, 2026, compromised versions of `@cap-js/[email protected]`, `@cap-js/[email protected]`, and `@cap-js/[email protected]` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. Patches Upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. Workarounds No workarounds.

Related

Alias · CVE (1)

  • CVE-2026-46421 The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo… vulnerability

Weakness · CWE (1)

  • CWE-506 Embedded Malicious Code weakness

References