GitHub Advisoryadvisory · Packagist

GHSA-pw34-qf6c-84fc phpMyAdmin XSS Vulnerability

MEDIUM Published 2022-05-14 Modified 2023-07-28 Official page ↗
Aliases
CVE-2016-2040
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-28

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.13 → fixed in 4.0.10.13 • Packagist phpmyadmin/phpmyadmin: >= 4.4, < 4.4.15.3 → fixed in 4.4.15.3 • Packagist phpmyadmin/phpmyadmin: >= 4.5, < 4.5.4 → fixed in 4.5.4

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.

Related

Alias · CVE (1)

  • CVE-2016-2040 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References