GitHub Advisoryadvisory · Packagist

GHSA-pw5c-xqf2-6xc2 Doctrine Security Misconfiguration Vulnerability

HIGH Published 2022-05-17 Modified 2023-10-19 Official page ↗
Aliases
CVE-2015-5723
Ecosystem
Packagist
Packages
doctrine/annotations, doctrine/cache, doctrine/common, doctrine/orm, doctrine/mongodb-odm, doctrine/mongodb-odm-bundle, zendframework/zendframework1, zendframework/zend-cache, aws/aws-sdk-php, zendframework/zendframework, zfcampus/zf-apigility-doctrine
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Reviewed
2023-10-19

Affected packages

• Packagist doctrine/annotations: < 1.2.7 → fixed in 1.2.7 • Packagist doctrine/cache: >= 1.4.0, < 1.4.2 → fixed in 1.4.2 • Packagist doctrine/common: < 2.4.3 → fixed in 2.4.3 • Packagist doctrine/common: >= 2.5.0-stable, < 2.5.1 → fixed in 2.5.1 • Packagist doctrine/orm: >= 2.5.0, < 2.5.1 → fixed in 2.5.1 • Packagist doctrine/mongodb-odm: < 1.0.2 → fixed in 1.0.2 • Packagist doctrine/mongodb-odm-bundle: < 3.0.1 → fixed in 3.0.1 • Packagist zendframework/zendframework1: >= 1.12.0, < 1.12.16 → fixed in 1.12.16 • Packagist zendframework/zend-cache: >= 2.5.0, < 2.5.3 → fixed in 2.5.3 • Packagist aws/aws-sdk-php: >= 3.0.0, < 3.2.1 → fixed in 3.2.1 • Packagist doctrine/cache: >= 1.0.0, < 1.3.2 → fixed in 1.3.2 • Packagist zendframework/zend-cache: >= 2.4.0, < 2.4.8 → fixed in 2.4.8 • Packagist zendframework/zendframework: >= 2.4.0, < 2.4.8 → fixed in 2.4.8 • Packagist zfcampus/zf-apigility-doctrine: >= 1.0.0, < 1.0.3 → fixed in 1.0.3

Description

Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.

Related

Alias · CVE (1)

  • CVE-2015-5723 Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8… vulnerability

References