GitHub Advisoryadvisory · npm

GHSA-pw8r-6689-xvf4 Angular Expressions - Remote Code Execution using filters

CRITICAL Published 2026-05-11 Modified 2026-05-13 Official page ↗
Aliases
CVE-2026-44643
Ecosystem
npm
Packages
angular-expressions
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-95
Reviewed
2026-05-11

Affected packages

• npm angular-expressions: < 1.5.2 → fixed in 1.5.2

Description

Impact An attacker can write a malicious expression that escapes the sandbox to execute arbitrary code on the system. Example of vulnerable code: ``` const expressions = require("angular-expressions"); const result = expressions.compile("a | __proto__")({}, {}); ``` This should throw the error : Filter '__proto__' is not defined, however, this shows : Uncaught SyntaxError: Unexpected identifier 'Object' With a more complex (undisclosed) payload, one can get full access to Arbitrary code execution on the system. Vulnerable versions : angular-expressions <= 1.5.1 Patches The problem has been patched in version 1.5.2 of angular-expressions. Credits Credits go to San Gil from www.securityoffice.io who has found the issue and reported it to us.

Related

Alias · CVE (1)

  • CVE-2026-44643 Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. vulnerability

Weakness · CWE (1)

  • CWE-95 Improper Neutralization of Directives in Dynamically Evaluated Code weakness

References