GitHub Advisoryadvisory · Maven
GHSA-pwfv-3cvg-9m4c org.xwiki.platform:xwiki-platform-oldcore makes Incorrect Use of Privileged APIs with DocumentAuthors
CRITICAL
Official page ↗
- Aliases
- CVE-2023-29507
- Ecosystem
- Maven
- Packages
- org.xwiki.platform:xwiki-platform-oldcore
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-648
- Reviewed
- 2023-04-12
Affected packages
• Maven org.xwiki.platform:xwiki-platform-oldcore: >= 14.5, < 14.10 → fixed in 14.10
• Maven org.xwiki.platform:xwiki-platform-oldcore: >= 14.4.1, < 14.4.7 → fixed in 14.4.7
Description
Impact
The Document script API returns directly a DocumentAuthors allowing to set any authors to the document, which in consequence can allow subsequent executions of scripts since this author is used for checking rights.
Example of such attack:
```
{{velocity}}
$doc.setContent('{{velocity}}$xcontext.context.authorReference{{/velocity}}')
$doc.authors.setContentAuthor('xwiki:XWiki.superadmin')
$doc.getRenderedContent()
{{/velocity}}
```
Patches
The problem has been patched in XWiki 14.10 and 14.4.7 by returning a safe script API.
Workarounds
There no easy workaround apart of upgrading.
References
• https://jira.xwiki.org/browse/XWIKI-20380
• https://github.com/xwiki/xwiki-platform/commit/905cdd7c421dbf8c565557cdc773ab1aa9028f83
For more information
If you have any questions or comments about this advisory:
• Open an issue in Jira
• Email us at security ML
Related
Alias · CVE (1)
- CVE-2023-29507 XWiki Commons are technical libraries common to several other top level XWiki projects. vulnerability
Weakness · CWE (1)
- CWE-648 Incorrect Use of Privileged APIs weakness
References
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-pwfv-3cvg-9m4c web
- https://nvd.nist.gov/vuln/detail/CVE-2023-29507 advisory
- https://github.com/xwiki/xwiki-platform/commit/905cdd7c421dbf8c565557cdc773ab1aa9028f83 web
- https://github.com/xwiki/xwiki-platform package
- https://jira.xwiki.org/browse/XWIKI-20380 web