GitHub Advisoryadvisory · Packagist

GHSA-pwgg-r6fq-mf94 YOURLS Stored Cross Site Scripting (XSS)

MEDIUM Published 2022-05-24 Modified 2024-01-10 Official page ↗
Aliases
CVE-2020-27388
Ecosystem
Packagist
Packages
yourls/yourls
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-10

Affected packages

• Packagist yourls/yourls: >= 1.5, < 1.8 → fixed in 1.8

Description

Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.

Related

Alias · CVE (1)

  • CVE-2020-27388 Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References