GitHub Advisoryadvisory · Packagist
GHSA-pwjq-fx3v-8f9r Drupal AI Vulnerable to OS Command Injection via Optional Automator Types
MEDIUM
Official page ↗
- Aliases
- CVE-2025-31692
- Ecosystem
- Packagist
- Packages
- drupal/ai
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-78
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/ai: < 1.0.5 → fixed in 1.0.5
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.
Related
Alias · CVE (1)
- CVE-2025-31692 Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial… vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness