GitHub Advisoryadvisory · Maven
GHSA-pwpc-hqq2-hx2x Cross-site Scripting in wicket-jquery-ui
MEDIUM
Official page ↗
- Aliases
- CVE-2017-15719
- Ecosystem
- Maven
- Packages
- com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-03
Affected packages
• Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent: < 6.28.1 → fixed in 6.28.1
• Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent: >= 7.0.0, < 7.9.2 → fixed in 7.9.2
• Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent: >= 8.0.0-M1, < 8.0.0-M8.1 → fixed in 8.0.0-M8.1
Description
In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.
Related
Alias · CVE (1)
- CVE-2017-15719 In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness