GitHub Advisoryadvisory · PyPI

GHSA-pwwp-3q7j-9mx8 Use After Free in MicroPython

MEDIUM Published 2024-09-17 Modified 2024-09-25 Official page ↗
Aliases
CVE-2024-8947
Ecosystem
PyPI
Packages
micropython-copy, micropython-io
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-416
Reviewed
2024-09-25

Affected packages

• PyPI micropython-copy: <= 3.3.3.post3 (no fix yet) • PyPI micropython-io: <= 0.1 (no fix yet)

Description

A vulnerability was found in MicroPython 1.22.2. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file py/objarray.c. The manipulation leads to use after free. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 1.23.0 is able to address this issue. The identifier of the patch is 4bed614e707c0644c06e117f848fa12605c711cd. It is recommended to upgrade the affected component. In micropython objarray component, when a bytes object is resized and copied into itself, it may reference memory that has already been freed.

Related

Alias · CVE (1)

  • CVE-2024-8947 A vulnerability was found in MicroPython 1.22.2. vulnerability

Weakness · CWE (1)

References