GitHub Advisoryadvisory · Maven

GHSA-px7w-c9gw-7gj3 Apache James server: Privilege escalation via JMX pre-authentication deserialization

CRITICAL Published 2024-02-27 Modified 2024-08-23 Official page ↗
Aliases
CVE-2023-51518
Ecosystem
Maven
Packages
org.apache.james:james-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2024-02-27

Affected packages

• Maven org.apache.james:james-server: < 3.7.5 → fixed in 3.7.5 • Maven org.apache.james:james-server: >= 3.8.0, < 3.8.1 → fixed in 3.8.1

Description

Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of untrusted data. Given a deserialisation gadjet, this could be leveraged as part of an exploit chain that could result in privilege escalation. Note that by default JMX endpoint is only bound locally. We recommend users to: • Upgrade to a non-vulnerable Apache James version • Run Apache James isolated from other processes (docker - dedicated virtual machine) • If possible turn off JMX

Related

Alias · CVE (1)

  • CVE-2023-51518 Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References