GitHub Advisoryadvisory · Maven

GHSA-q24v-hpg3-v3jp Reactor Netty HTTP Server denial of service vulnerability

HIGH Published 2023-11-28 Modified 2024-06-28 Official page ↗
Aliases
CVE-2023-34054
Ecosystem
Maven
Packages
io.projectreactor.netty:reactor-netty-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2023-11-28

Affected packages

• Maven io.projectreactor.netty:reactor-netty-core: >= 1.1.0, < 1.1.13 → fixed in 1.1.13 • Maven io.projectreactor.netty:reactor-netty-core: >= 1.0.0, < 1.0.39 → fixed in 1.0.39

Description

In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable if Reactor Netty HTTP Server built-in integration with Micrometer is enabled.

Related

Alias · CVE (1)

  • CVE-2023-34054 In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide… vulnerability

References