GitHub Advisoryadvisory · Packagist
GHSA-q25h-jch8-gfrp Concrete CMS vulnerable to stored XSS via the Role Name field
LOW
Official page ↗
- Aliases
- CVE-2024-1247
- Ecosystem
- Packagist
- Packages
- concrete5/concrete5
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20, CWE-79
- Reviewed
- 2024-02-09
Affected packages
• Packagist concrete5/concrete5: >= 9.0.0RC1, < 9.2.5 → fixed in 9.2.5
Description
Concrete CMS version 9 before 9.2.5 is vulnerable to stored XSS via the Role Name field since there is insufficient validation of administrator provided data for that field. A rogue administrator could inject malicious code into the Role Name field which might be executed when users visit the affected page. The Concrete CMS Security team scored this 2 with CVSS v3 vector AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Concrete versions below 9 do not include group types so they are not affected by this vulnerability.
Related
Alias · CVE (1)
- CVE-2024-1247 Concrete CMS version 9 before 9.2.5 is vulnerable to stored XSS via the Role Name field since there is insufficient validation of… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-1247 advisory
- https://github.com/concretecms/concretecms/commit/59a07472ad6349a2c5fb455837a54ed1fe3f6953 web
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/925-release-notes web
- https://github.com/concretecms/concretecms package
- https://www.concretecms.org/about/project-news/security/2024-02-04-security-advisory web