GitHub Advisoryadvisory · Maven
GHSA-q25j-gcmv-5qpp Stored Cross Site Scripting in Grails Fields Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000529
- Ecosystem
- Maven
- Packages
- org.grails.plugins:fields, org.grails:grails-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• Maven org.grails.plugins:fields: < 2.2.8 → fixed in 2.2.8
• Maven org.grails:grails-core: < 3.3.6 → fixed in 3.3.6
Description
Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in using the display tag that can result in XSS. This vulnerability has been fixed in version 2.2.8.
Related
Alias · CVE (1)
- CVE-2018-1000529 Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness