GitHub Advisoryadvisory · npm

GHSA-q2c6-c6pm-g3gh Arbitrary Code Execution in handlebars

HIGH Published 2020-09-04 Modified 2020-08-31 Official page ↗
Ecosystem
npm
Packages
handlebars
Severity
High
Reviewed
2020-08-31

Affected packages

• npm handlebars: < 3.0.8 → fixed in 3.0.8 • npm handlebars: >= 4.0.0, < 4.5.3 → fixed in 4.5.3

Description

Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a previous issue. This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). Recommendation Upgrade to version 3.0.8, 4.5.3 or later.

References