GitHub Advisoryadvisory · Maven
GHSA-q35p-chc6-7x57 Moderate severity vulnerability that affects org.apache.storm:storm-core
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1332
- Ecosystem
- Maven
- Packages
- org.apache.storm:storm-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2020-06-16
Affected packages
• Maven org.apache.storm:storm-core: < 1.1.3 → fixed in 1.1.3
• Maven org.apache.storm:storm-core: >= 1.2.0, < 1.2.2 → fixed in 1.2.2
Description
Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.
Related
Alias · CVE (1)
- CVE-2018-1332 Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to… vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness