GitHub Advisoryadvisory · npm
GHSA-q3f4-9h4p-vgr3 secp256k1-js implements ECDSA without required r and s validation, leading to signature forgery
HIGH
Official page ↗
- Aliases
- CVE-2022-41340
- Ecosystem
- npm
- Packages
- @lionello/secp256k1-js
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-347
- Reviewed
- 2022-09-27
Affected packages
• npm @lionello/secp256k1-js: < 1.1.0 → fixed in 1.1.0
Description
The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery.
Related
Alias · CVE (1)
- CVE-2022-41340 The secp256k1-js package before 1.1.0 for Node.js implements ECDSA without required r and s validation, leading to signature forgery. vulnerability
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-41340 advisory
- https://github.com/lionello/secp256k1-js/issues/11 web
- https://github.com/lionello/secp256k1-js/commit/302800f0370b42e360a33774bb808274ac729c2e web
- https://github.com/lionello/secp256k1-js package
- https://github.com/lionello/secp256k1-js/compare/1.0.1...1.1.0 web
- https://www.npmjs.com/package/@lionello/secp256k1-js web