GitHub Advisoryadvisory · Packagist
GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- shopware/shopware
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2024-05-21
Affected packages
• Packagist shopware/shopware: >= 4.0.0, < 5.2.15 → fixed in 5.2.15
• Packagist shopware/shopware: < 1.0.8 → fixed in 1.0.8
Description
Under certain circumstances, it’s possible to execute an unauthorized foreign code in Shopware. This is a critical security vulnerability that could affect the entire system. All Shopware versions including Shopware 5.2.14 are affected.
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://github.com/shopware5/shopware/commit/14299e9ee9f7d93f687b4ec838e0873afbc84fec web
- https://community.shopware.com/_detail_1989.html web
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-01-2017?category=shopware-5-en/security-updates web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/shopware/shopware/2017-01-24.yaml web
- https://github.com/shopware5/shopware package