GitHub Advisoryadvisory · Maven

GHSA-q3rp-555r-hh6r Jenkins allows Cross-Site Scripting (XSS)

LOW Published 2022-05-17 Modified 2025-03-13 Official page ↗
Aliases
CVE-2011-4344
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-79
Reviewed
2025-03-13

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: < 1.409.3 → fixed in 1.409.3 • Maven org.jenkins-ci.main:jenkins-core: >= 1.410, < 1.438 → fixed in 1.438

Description

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Related

Alias · CVE (1)

  • CVE-2011-4344 Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References