GitHub Advisoryadvisory · PyPI
GHSA-q492-f7gr-27rp Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow
HIGH
Official page ↗
- Aliases
- CVE-2018-10055
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
- Weaknesses
- CWE-119
- Reviewed
- 2019-04-30
Affected packages
• PyPI tensorflow: >= 1.1.0, < 1.7.1 → fixed in 1.7.1
• PyPI tensorflow-gpu: >= 1.1.0, < 1.7.1 → fixed in 1.7.1
Description
Invalid memory access and/or a heap buffer overflow in the TensorFlow XLA compiler in Google TensorFlow before 1.7.1 could cause a crash or read from other parts of process memory via a crafted configuration file.
Related
Alias · CVE (1)
- CVE-2018-10055 Invalid memory access and/or a heap buffer overflow in the TensorFlow XLA compiler in Google TensorFlow before 1.7.1 could cause a crash or… vulnerability
Weakness · CWE (1)
- CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10055 advisory
- https://github.com/tensorflow/tensorflow/commit/c89ab82a82585cdaa90bf4911980e9e845909e78 web
- https://github.com/advisories/GHSA-q492-f7gr-27rp advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-222.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-229.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-204.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-006.md web