GitHub Advisoryadvisory · npm
GHSA-q4gf-8mx6-v5v3 Next.js has a Denial of Service with Server Components
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
- Reviewed
- 2026-04-10
Affected packages
• npm next: >= 13.0.0, < 15.5.15 → fixed in 15.5.15
• npm next: >= 16.0.0-beta.0, < 16.2.3 → fixed in 16.2.3
Description
A vulnerability affects certain React Server Components packages for versions 19.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as CVE-2026-23869. You can read more about this advisory our this changelog.
A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage. This can result in denial of service in unpatched environments.
Related
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness