GitHub Advisoryadvisory · npm, Maven

GHSA-q4q5-c5cv-2p68 Vuetify Cross-site Scripting vulnerability

MEDIUM Published 2022-09-19 Modified 2022-09-21 Official page ↗
Aliases
CVE-2022-25873
Ecosystem
npm, Maven
Packages
vuetify, org.webjars.npm:vuetify
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-09-21

Affected packages

• npm vuetify: >= 2.0.0-beta.4, < 2.6.10 → fixed in 2.6.10 • Maven org.webjars.npm:vuetify: >= 2.0.0-beta.4, < 2.6.10 → fixed in 2.6.10

Description

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

Related

Alias · CVE (1)

  • CVE-2022-25873 The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References