GitHub Advisoryadvisory · Packagist

GHSA-q53j-c866-h9mw Moodle doesn't properly check role

LOW Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2010-1617
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-862
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 1.8.0, < 1.8.12 → fixed in 1.8.12 • Packagist moodle/moodle: >= 1.9.0, < 1.9.8 → fixed in 1.9.8

Description

user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users to obtain the full names of other users via the course profile page.

Related

Alias · CVE (1)

  • CVE-2010-1617 user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users… vulnerability

Weakness · CWE (1)

  • CWE-862 Missing Authorization weakness

References