GitHub Advisoryadvisory · Packagist

GHSA-q56r-mw39-944g Concrete CMS vulnerable to Improper Authentication

MEDIUM Published 2022-11-15 Modified 2022-11-22 Official page ↗
Aliases
CVE-2022-43690
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Weaknesses
CWE-287
Reviewed
2022-11-22

Affected packages

• Packagist concrete5/concrete5: < 8.5.10 → fixed in 8.5.10 • Packagist concrete5/concrete5: >= 9.0.0, < 9.1.3 → fixed in 9.1.3

Description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that limited authentication bypass could occur if using this functionality. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Related

Alias · CVE (1)

  • CVE-2022-43690 Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References