GitHub Advisoryadvisory · Packagist
GHSA-q586-xpwr-jc3j phpMyAdmin cross-site scripting vulnerability in crafted view name
LOW
Official page ↗
- Aliases
- CVE-2014-5274
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Low
- Weaknesses
- CWE-79
- Reviewed
- 2023-08-16
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.1.0, < 4.1.14.3 → fixed in 4.1.14.3
• Packagist phpmyadmin/phpmyadmin: >= 4.2.0, < 4.2.7.1 → fixed in 4.2.7.1
Description
A cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to `js/functions.js`.
Related
Alias · CVE (1)
- CVE-2014-5274 Cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness