GitHub Advisoryadvisory · RubyGems
GHSA-q58j-fmvf-9rq6 Cross site scripting in actionpack Rubygem
MEDIUM
Official page ↗
- Aliases
- CVE-2011-1497
- Ecosystem
- RubyGems
- Packages
- actionpack
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-17
Affected packages
• RubyGems actionpack: >= 3.0.0.rc, < 3.0.6 → fixed in 3.0.6
Description
A cross-site scripting vulnerability flaw was found in the `auto_link` function in Rails before version 3.0.6.
Related
Alias · CVE (1)
- CVE-2011-1497 A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-1497 advisory
- https://github.com/rails/rails/commit/61ee3449674c591747db95f9b3472c5c3bd9e84d web
- https://github.com/rails/rails/commit/ab764ecbfea31a3b14323283287e2fc80955ace6 web
- https://github.com/rails/rails package
- https://github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2011-1497.yml web
- https://www.openwall.com/lists/oss-security/2011/04/06/13 web