GitHub Advisoryadvisory · Maven

GHSA-q5j9-f95w-f4pr TERASOLUNA Server Framework vulnerable to ClassLoader manipulation

HIGH Published 2022-12-05 Modified 2022-12-06 Official page ↗
Aliases
CVE-2022-43484
Ecosystem
Maven
Packages
org.terasoluna.gfw:terasoluna-gfw-common
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2022-12-05

Affected packages

• Maven org.terasoluna.gfw:terasoluna-gfw-common: < 1.0.1.RELEASE → fixed in 1.0.1.RELEASE

Description

TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable to ClassLoader manipulation due to using the old version of Spring Framework which contains the vulnerability. The vulnerability is caused by an improper input validation issue in the binding mechanism of Spring MVC. By the application processing a specially crafted file, arbitrary code may be executed with the privileges of the application. When using TERASOLUNA Global Framework 1.0.0 (Public review version), update to TERASOLUNA Server Framework for Java 5.7.1.SP1 (using Spring Framework 5.3.18). This vulnerability alone can be addressed by updating to TERASOLUNA Global Framework 1.0.1 (using Spring Framework 3.2.10) or later.

Related

Alias · CVE (1)

  • CVE-2022-43484 TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References