GitHub Advisoryadvisory · PyPI

GHSA-q5qw-4364-5hhm Django Vulnerable to HTTP Response Splitting Attack

HIGH Published 2022-05-17 Modified 2024-09-18 Official page ↗
Aliases
CVE-2015-5144
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20
Reviewed
2023-08-04

Affected packages

• PyPI Django: < 1.4.21 → fixed in 1.4.21 • PyPI Django: >= 1.5, < 1.7.9 → fixed in 1.7.9 • PyPI Django: >= 1.8a1, < 1.8.3 → fixed in 1.8.3

Description

Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP response splitting attacks via a newline character in an (1) email message to the EmailValidator, a (2) URL to the URLValidator, or unspecified vectors to the (3) validate_ipv4_address or (4) validate_slug validator.

Related

Alias · CVE (1)

  • CVE-2015-5144 Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References