GitHub Advisoryadvisory · Packagist
GHSA-q628-54wg-4r5q Magento does not properly restrict excessive authentication attempts
HIGH
Official page ↗
- Aliases
- CVE-2024-39398
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-307
- Reviewed
- 2025-11-06
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p2 → fixed in 2.4.7-p2
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p7 → fixed in 2.4.6-p7
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p9 → fixed in 2.4.5-p9
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p10 → fixed in 2.4.4-p10
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
Description
Magento versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Restriction of Excessive Authentication Attempts vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability to perform brute force attacks and potentially gain unauthorized access to accounts. Exploitation of this issue does not require user interaction, but attack complexity is high.
Related
Alias · CVE (1)
- CVE-2024-39398 Adobe Commerce versions 2.4.7-p1, 2.4.6-p6, 2.4.5-p8, 2.4.4-p9 and earlier are affected by an Improper Restriction of Excessive… vulnerability
Weakness · CWE (1)
- CWE-307 Improper Restriction of Excessive Authentication Attempts weakness