GitHub Advisoryadvisory · Maven

GHSA-q672-hfc7-g833 Apache Druid Vulnerable to Authentication Bypass

CRITICAL Published 2026-02-10 Modified 2026-02-12 Official page ↗
Aliases
CVE-2026-23906
Ecosystem
Maven
Packages
org.apache.druid.extensions:druid-basic-security
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-287
Reviewed
2026-02-10

Affected packages

• Maven org.apache.druid.extensions:druid-basic-security: >= 0.17.0, < 36.0.0 → fixed in 36.0.0

Description

Affected Products and Versions • Apache Druid • Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0) • Prerequisites: * druid-basic-security extension enabled • LDAP authenticator configured • Underlying LDAP server permits anonymous bind                                                                                                                                                    Vulnerability Description An authentication bypass vulnerability exists in Apache Druid when using the druid-basic-security extension with LDAP authentication. If the underlying LDAP server is configured to allow anonymous binds, an attacker can bypass authentication by providing an existing username with an empty password. This allows unauthorized access to otherwise restricted Druid resources without valid credentials. The vulnerability stems from improper validation of LDAP authentication responses when anonymous binds are permitted, effectively treating anonymous bind success as valid user authentication. Impact A remote, unauthenticated attacker can: • Gain unauthorized access to the Apache Druid cluster • Access sensitive data stored in Druid datasources • Execute queries and potentially manipulate data • Access administrative interfaces if the bypassed account has elevated privileges • Completely compromise the confidentiality, integrity, and availability of the Druid deployment                                                                                                                                                                                     Mitigation   Immediate Mitigation (No Druid Upgrade Required):                                                                                                                                                   • Disable anonymous bind on your LDAP server. This prevents the vulnerability from being exploitable and is the recommended immediate action. Resolution • Upgrade Apache Druid to version 36.0.0 or later, which includes fixes to properly reject anonymous LDAP bind attempts.

Related

Alias · CVE (1)

  • CVE-2026-23906 Affected Products and Versions * Apache Druid * Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0) * Prerequisites: *… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References