GitHub Advisoryadvisory · npm

GHSA-q6mq-ch85-c8mm Payload: Password hashes use insufficient PBKDF2 iterations

MEDIUM Published 2026-10-06 Modified 2026-10-06 Official page ↗
Aliases
CVE-2026-105804
Ecosystem
npm
Packages
payload
Severity
Moderate
CVSS vector
CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-916
Reviewed
2026-10-06

Affected packages

• npm payload: >= 3.0.0, < 3.90.0 → fixed in 3.90.0 • npm payload: >= 4.0.0-canary.0, < 4.0.0-canary.34 → fixed in 4.0.0-canary.34

Description

Impact The password-hashing configuration used a lower work factor than what is recommended. Patches Payload now uses stronger password-hashing parameters and transparently upgrades older hashes following a successful login. Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. Workarounds Upgrading is recommended. Until you can upgrade, protect database copies and backups from unauthorized access and require strong, unique passwords.

Related

Alias · CVE (1)

  • CVE-2026-105804 Payload is a free and open source headless content management system. vulnerability

Weakness · CWE (1)

  • CWE-916 Use of Password Hash With Insufficient Computational Effort weakness

References