GitHub Advisoryadvisory · Packagist

GHSA-q6vw-39cg-wjjf phpMyAdmin Directory Traversal vulnerability

HIGH Published 2022-05-14 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-2508
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
Weaknesses
CWE-22
Reviewed
2025-04-12

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.3.0, < 3.3.10.2 → fixed in 3.3.10.2 • Packagist phpmyadmin/phpmyadmin: >= 3.4.0, < 3.4.3.1 → fixed in 3.4.3.1

Description

Directory traversal vulnerability in libraries/display_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a certain MIME transformation feature is enabled, allows remote authenticated users to include and execute arbitrary local files via a .. (dot dot) in a GLOBALS[mime_map][$meta->name][transformation] parameter.

Related

Alias · CVE (1)

  • CVE-2011-2508 Directory traversal vulnerability in libraries/display_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References