GitHub Advisoryadvisory · Maven

GHSA-q74x-qqhr-f8rx Apache Tomcat Cross-site scripting (XSS) vulnerability

MEDIUM Published 2022-05-01 Modified 2023-09-22 Official page ↗
Aliases
CVE-2008-1232
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2023-09-22

Affected packages

• Maven org.apache.tomcat:tomcat: >= 4.1.0, < 4.1.38 → fixed in 4.1.38 • Maven org.apache.tomcat:tomcat: >= 5.5.0, < 5.5.27 → fixed in 5.5.27 • Maven org.apache.tomcat:tomcat: >= 6.0.0, < 6.0.17 → fixed in 6.0.17

Description

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via a crafted string that is used in the message argument to the HttpServletResponse.sendError method.

Related

Alias · CVE (1)

  • CVE-2008-1232 Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16 allows… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References