GitHub Advisoryadvisory · Packagist
GHSA-q754-vwc4-p6qj Authenticated Stored Cross-site Scripting in Shopware
MEDIUM
Official page ↗
- Aliases
- CVE-2022-31057
- Ecosystem
- Packagist
- Packages
- shopware/shopware
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-22
Affected packages
• Packagist shopware/shopware: < 5.7.12 → fixed in 5.7.12
Description
Impact
Authenticated Stored XSS in Administration
Patches
We recommend updating to version 5.7.12. You can get the update to 5.7.12 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/de/changelog-sw5/#5-7-12
For older versions you can use the Security Plugin:
https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022
Related
Alias · CVE (1)
- CVE-2022-31057 Shopware is an open source e-commerce software made in Germany. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/shopware/shopware/security/advisories/GHSA-q754-vwc4-p6qj web
- https://nvd.nist.gov/vuln/detail/CVE-2022-31057 advisory
- https://github.com/shopware/shopware/commit/3e025a0a3e123f4108082645b1ced6fb548f7b6f web
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022 web
- https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2022?_ga=2.237805696.1286760707.1655914110-2145019146.1655914110 web
- https://github.com/shopware/shopware package
- https://packagist.org/packages/shopware/shopware web
- https://www.shopware.com/en/changelog-sw5/#5-7-12 web