GitHub Advisoryadvisory · Maven

GHSA-q7pf-qr96-2vq5 Deserialization of Untrusted Data in swagger-parser

HIGH Published 2018-10-19 Modified 2022-09-14 Official page ↗
Aliases
CVE-2017-1000208
Ecosystem
Maven
Packages
io.swagger:swagger-codegen, io.swagger:swagger-parser
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2020-06-16

Affected packages

• Maven io.swagger:swagger-codegen: < 2.2.2 → fixed in 2.2.2 • Maven io.swagger:swagger-parser: < 1.0.31 → fixed in 1.0.31

Description

A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

Related

Alias · CVE (1)

  • CVE-2017-1000208 A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References