GitHub Advisoryadvisory · PyPI

GHSA-q7q4-5g8p-33fq MoinMoin Multiple cross-site scripting (XSS) vulnerabilities

MEDIUM Published 2022-05-01 Modified 2024-11-26 Official page ↗
Aliases
CVE-2008-3381
Ecosystem
PyPI
Packages
moin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-14

Affected packages

• PyPI moin: < 1.6.4 → fixed in 1.6.4 • PyPI moin: >= 1.7.0, < 1.7.1 → fixed in 1.7.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in `macro/AdvancedSearch.py` in moin (and MoinMoin) 1.6.3 and 1.7.0 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2008-3381 Multiple cross-site scripting (XSS) vulnerabilities in macro/AdvancedSearch.py in moin (and MoinMoin) 1.6.3 and 1.7.0 allow remote… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References