GitHub Advisoryadvisory · NuGet
GHSA-q7x5-x7rr-2859 PowerShell Elevation of Privilege Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-26788
- Ecosystem
- NuGet
- Packages
- Microsoft.PowerShell.SDK
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2025-10-13
Affected packages
• NuGet Microsoft.PowerShell.SDK: >= 7.0.0-preview.1, < 7.0.10 → fixed in 7.0.10
• NuGet Microsoft.PowerShell.SDK: >= 7.1.0-preview.1, < 7.1.7 → fixed in 7.1.7
• NuGet Microsoft.PowerShell.SDK: >= 7.2.0-preview.1, < 7.2.3 → fixed in 7.2.3
Description
PowerShell Elevation of Privilege Vulnerability.
Related
Alias · CVE (1)
- CVE-2022-26788 PowerShell Elevation of Privilege Vulnerability vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-26788 advisory
- https://github.com/PowerShell/Announcements/issues/31 web
- https://github.com/PowerShell/PowerShell package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-26788 web
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-26788 web