GitHub Advisoryadvisory · npm
GHSA-q849-wxrc-vqrp hull.js Code Injection Vulnerability
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- hull.js
- Severity
- Critical
- Weaknesses
- CWE-94
- Reviewed
- 2024-12-02
Affected packages
• npm hull.js: >= 0.2.2, < 1.0.10 → fixed in 1.0.10
Description
Versions of the library from 0.2.2 to 1.0.9 are vulnerable to the arbitrary code execution due to unsafe usage of `new Function(...)` in the module that handles points format. Applications passing the 3rd parameter to the `hull` function without sanitising may be impacted. The vulnerability has been fixed in version 1.0.10, please update the library. Check project homepage on GitHub to see how to fetch the latest version: https://github.com/andriiheonia/hull?tab=readme-ov-file#npm-package
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness