GitHub Advisoryadvisory · PyPI

GHSA-q874-g24w-4q9g Jupyter server Token bruteforcing

HIGH Published 2022-06-16 Modified 2023-10-26 Official page ↗
Aliases
CVE-2022-29241
Ecosystem
PyPI
Packages
jupyter-server
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Reviewed
2022-06-16

Affected packages

• PyPI jupyter-server: < 1.17.1 → fixed in 1.17.1 • PyPI jupyter-server: >= 2.0.0a0, < 2.0.0a1 → fixed in 2.0.0a1

Description

Affects: Notebook and Lab between 6.4.0?(potentially earlier) and 6.4.11 (currently latest). Jupyter Server <=1.16.0. If I am correct about the responsible code it will affect Jupyter-Server 1.17.0 and 2.0.0a0 as well. Description: If notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this url can be used from an xss payload (as in CVE-2021-32798) or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system.

Related

Alias · CVE (1)

  • CVE-2022-29241 Jupyter Server provides the backend (i.e. vulnerability

References