GitHub Advisoryadvisory · Go
GHSA-q8fg-cp3q-5jwm Mattermost Incorrect Authorization vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-22449
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-01-09
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.6 → fixed in 9.11.6
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250102081831-64c566a8280b → fixed in 8.0.0-20250102081831-64c566a8280b
Description
Mattermost versions 9.11.x <= 9.11.5 fail to enforce invite permissions, which allows team admins, with no permission to invite users to their team, to invite users by updating the "allow_open_invite" field via making their team public.
Related
Alias · CVE (1)
- CVE-2025-22449 Mattermost versions 9.11.x <= 9.11.5 fail to enforce invite permissions, which allows team admins, with no permission to invite users to… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness