GitHub Advisoryadvisory · npm
GHSA-q8pj-2vqx-8ggc Denial of service in css-what
HIGH
Official page ↗
- Aliases
- CVE-2021-33587
- Ecosystem
- npm
- Packages
- css-what
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2021-06-01
Affected packages
• npm css-what: >= 4.0.0, < 5.0.1 → fixed in 5.0.1
Description
The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.
Related
Alias · CVE (1)
- CVE-2021-33587 The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-33587 advisory
- https://github.com/fb55/css-what/commit/4cdaacfd0d4b6fd00614be030da0dea6c2994655 web
- https://github.com/fb55/css-what package
- https://github.com/fb55/css-what/releases/tag/v5.0.1 web
- https://lists.debian.org/debian-lts-announce/2023/03/msg00001.html web
- https://security.netapp.com/advisory/ntap-20210706-0007 web