GitHub Advisoryadvisory · RubyGems
GHSA-q95h-cqrv-8jv5 ExifTool vulnerable to arbitrary code execution
HIGH
Official page ↗
- Ecosystem
- RubyGems
- Packages
- exiftool_vendored
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2023-01-20
Affected packages
• RubyGems exiftool_vendored: < 12.25.0 → fixed in 12.25.0
Description
Impact
Arbitrary code execution can occur when running `exiftool` against files with hostile metadata payloads
Patches
ExifTool has already been patched in version 12.24. `exiftool_vendored.rb`, which vendors ExifTool, includes this patch in v12.25.0.
Workarounds
No
References
https://twitter.com/wcbowling/status/1385803927321415687
https://nvd.nist.gov/vuln/detail/CVE-2021-22204
For more information
If you have any questions or comments about this advisory:
Open an issue in exiftool_vendored.rb
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness