GitHub Advisoryadvisory · Maven
GHSA-q95j-488q-5q3p Apiman Manager API affected by Jackson denial of service vulnerability
MEDIUM
Official page ↗
- Ecosystem
- Maven
- Packages
- io.apiman:apiman-manager-api-impl
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-787
- Reviewed
- 2023-01-09
Affected packages
• Maven io.apiman:apiman-manager-api-impl: < 3.0.0.Final → fixed in 3.0.0.Final
Description
Impact
Due to a vulnerability in `jackson-databind <= 2.12.6.0`, an authenticated attacker could craft an Apiman policy configuration which, when saved, may cause a denial of service on the Apiman Manager API.
This does not affect the Apiman Gateway.
Patches
Upgrade to Apiman 3.0.0.Final or later.
If you are using an older version of Apiman and need to remain on that version, contact your Apiman support provider for advice/long-term support.
Workarounds
If all users of the Apiman Manager are trusted then you may assess this is low risk, as an account is required to exploit the vulnerability.
References
• Apiman maintainer and security contact: [email protected]
• https://nvd.nist.gov/vuln/detail/CVE-2020-36518
• https://github.com/FasterXML/jackson-databind/issues/2816
Related
Weakness · CWE (1)
- CWE-787 Out-of-bounds Write weakness