GitHub Advisoryadvisory · Packagist

GHSA-q97c-2mh3-pgw9 Shopware dependency configuration exposed

MEDIUM Published 2023-06-28 Modified 2023-06-28 Official page ↗
Aliases
CVE-2023-34098
Ecosystem
Packagist
Packages
shopware/shopware
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2023-06-28

Affected packages

• Packagist shopware/shopware: >= 5.6.0, < 5.7.18 → fixed in 5.7.18

Description

Impact Due to a wrong configuration in the `.htaccess` file, the configuration file of Javascript dependencies could be read in production environments (`themes/package-lock.json`). With this information, the used Shopware version might be determined by an attacker, which could be used for further attacks. Patches We recommend updating to the current version 5.7.18. You can get the update to 5.7.18 regularly via the Auto-Updater or directly via the release page. https://github.com/shopware5/shopware/releases/tag/v5.7.18 For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2023

Related

Alias · CVE (1)

  • CVE-2023-34098 Shopware is an open source e-commerce software. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References